Doom Delta is a gameplay mod for the GZDoom sourceport that aims to incorporate various elements from the pre-release iterations of Doom. This includes early HUD designs, unused weapon and monster concepts, and four unique playable characters.

Yep!

Doom Delta 2.4.0 requires GZDoom v4.7.1 to run. You will also need Doom, of course! Either Doom or Doom II will work.

Doom Delta v2.4.0 (nothing yet)